System requirements

For new hardware purchases, we recommend the following system configuration:

  • Support for OpenGL 4.6

  • Dedicated graphics memory: 4GB or more

  • Graphics card: on Windows, and especially on Linux, a recent NVIDIA GPU

    • Geforce GTX 10xx or better

    • Quadro Pxxxx or better

On Mac systems, a dedicated graphics card is recommended over an integrated GPU.

  • CPU: Quad core CPU

  • Main memory: 4GB or more

With these system specifications, you are able to run any LuciadLightspeed application with optimal speed and performance.

Minimum system requirements

  • For hardware-accelerated visualization using a Lightspeed view:

    • Main memory: 2 GB

    • Graphics card: OpenGL 4.2 capable GPU

    • Graphics memory: 1 GB

    • ATI/AMD graphics cards on Linux are discouraged because of driver issues

    • Individual API components, such as density layers, may impose additional requirements on the OpenGL implementation

  • For hardware-accelerated line-of-sight calculations and image processing: OpenCL 1.0 driver with support for double precision floating point computations (cl_khr_fp64)

OpenGL 4.2 is the minimum for Lightspeed views. However, a driver that supports OpenGL 4.6 is strongly recommended, because lack of support for the latest version of OpenGL may indicate that the driver is not actively maintained. This in turn means that it is more likely to show instability, sub-par performance or graphical glitches. Therefore, please check regularly if any graphics driver updates are available for your system. If you are working in a virtualized environment, a VM properly configured to use NVIDIA vGPU for GPU virtualization will provide the best results. If no OpenGL 4.2-compliant graphics driver is available, the software-based ILcdGXYView may provide a better user experience on your platform.

Supported platforms

You can develop and deploy LuciadLightspeed applications with hardware acceleration on the following platforms:

Platform Version Operating System Architecture Supported GPU Vendors


Windows 8.1 and above



Windows Server

2012 and above




Various distributions

x86-64 (*)



10.9 and above



Support for multi-touch events in Swing applications is available only on Windows.

(*) The software-based ILcdGXYView is also supported on 32-bit Linux systems.

Linux support

LuciadLightspeed requires a minimum glibc (GNU C Library) version of 2.27 and the C++ ABI introduced in GCC 5.1.

This means that, among others, the following OS distributions are supported:

  • Red Hat Enterprise Linux 8 or newer

  • OpenSUSE Leap 15.3 or newer

  • Ubuntu 18.04 or newer

  • Debian 10 or newer

Linux distributions using old ABI

LuciadLightspeed does not support Linux distributions using the old ABI. This means that you cannot develop and deploy LuciadLightspeed on RHEL 7 or CentOS 7.


As a Java API, LuciadLightspeed requires a JDK for development and a JRE for deployment.

Table 1, “Supported Java versions” gives an overview of the supported Java versions.

Luciad aims to support the latest Java LTS version in its latest releases. The minimum JDK/JRE requirements never change with a minor upgrade (an upgrade from 2022.0 to 2022.1, for instance) or a patch release of LuciadLightspeed.

Table 1. Supported Java versions
OracleJDK OpenJDK

LuciadLightspeed 2017 and earlier


not supported

LuciadLightspeed 2018 [1]

8, 11


LuciadLightspeed 2019

8, 11


LuciadLightspeed 2020

8, 11


LuciadLightspeed 2021 [2]

8, 11, 17

11, 17

LuciadLightspeed 2022

8, 11, 17

11, 17

LuciadLightspeed 2023

8, 11, 17

11, 17

LuciadLightspeed 2024 [3]

17, 21

17, 21

For users of Mac computers with Apple silicon

Even though you’re using an ARM-based processor, download and install a JDK for an x86 64-bit architecture instead of an ARM-based JDK.

We recommend using the latest version of any long-term support (LTS) release. At the time of writing, the LTS releases are Java 8, Java 11, and Java 17.

We haven’t encountered any provider-specific issues. LuciadLightspeed is regularly tested using OracleJDK, Adoptium Temurin, Liberica, and several other Java providers.

OpenJDK 8 considerations

LuciadLightspeed doesn’t officially support OpenJDK 8. The minimum supported version is OpenJDK 11 at the time of writing. We don’t test LuciadLightspeed on OpenJDK 8, but in practice, recent LuciadLightspeed versions seem to work fine on it.

JDK 11 and JDK 17 considerations

LuciadLightspeed supports JDK 11 and JDK 17 in compatibility mode. If you want to get rid of illegal access warnings or errors, use the --add-opens <module_name>/<package_name>=<reflectingmodule> flags. If you set the reflectingmodule value to ALL-UNNAMED, you allow all classes from the classpath to access the package.

In practice, any illegal access violation will come from these third-party libraries:

  • JIDE, used by Lucy’s tabbed interface front-end. This does not affect Lucy Map Centric.

  • JAI, used to:

    • Save models to GeoTIFF

    • Enable non-hardware-accelerated imaging operations

Supported JVM implementations

We support the HotSpot JVM.


JavaFX has been removed from JDK 11 and JDK 17. To compile a LuciadLightspeed application with JDK 11 or later, you need to use the OpenJFX library, or use a JDK that has OpenJFX included. For information on how to get started with OpenJFX, see the OpenJFX website. If your application does not use the JavaFX features in LuciadLightspeed, OpenJFX will not be required at runtime.

1. As of 2018.1
2. As of 2021.1
3. Expected in 2024, actual supported versions can still change